How do I disable search completely?

Developer Space

Developer Space
Want to extend the Telligent Evolution platform? Collaborate with other developers and product experts here.

How do I disable search completely?

This question is answered

Since search is listed as optional, what is the best way to stop the multiple exceptions caused by the fact search isn't installed?

Namely:

Message:  Http error in request/response to http://localhost:8080/solr/update/
System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8080
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)

And is there anything else that relies on this service running? I believe I read that RSS relies on solr?

Verified Answer
  • You will need to remove the Search header fragment from your theme, and also disable the search indexing task in communityserver.config.

    At the moment, the only reliance on search is RSS.

  • Perfect, thanks Alex. The search box went long ago in our custom theme, so this is pleasantly easy. I was expecting some pain :)

  • We are experiencing the same issue reported above.  

    Message: There was an error processing search queue message '06674ad6-4b88-4e27-ba59-63234d100c44'.Http error in request/response to http://localhost:8080/solr/update/

    System.Exception: Http error in request/response to http://localhost:8080/solr/update/

    at CommunityServer.Search.Solr.WebRequests.Post(String url, Byte[] bytesToPost, String& statusDescription)

    at CommunityServer.Search.Solr.SolrSearchIndexProvider.RemoveFromIndexByQuery(SearchQuery query)

    at CommunityServer.Search.Tasks.DeleteQueryRunner.Execute()

    We've attempted to disable the searchDeleteQueue and SearchIndexJob in the communityserver.config but it seems to have no affect.  Is there another solution that we should try?

    Thanks for your help in advance.

  • Hi Nick,

    How are you doing this, with an override file or in the CommunityServer.config itself?

    Also are you disabling or removing the task altogether and have you save the web.config once you made the change?

    Thanks

    Adam

  • Hi Alex/Adam,

    I did as mentioned but no success, the job still runs :(

    1. <task name="SearchDeleteQueue" type="CommunityServer.Search.Tasks.DeleteQueryRunner, CommunityServer.Search" enabled="false" enableShutDown="true" />

    <

     

    task name="SearchIndexJob" type="Telligent.Search.Mapping.ContentHandlerTask, Telligent.Search.Mapping" documentsPerRun="100" enabled="false" enableShutDown="true">

    <

     

    handler type="CommunityServer.Search.UserContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.GroupContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ForumContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WeblogContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ContentFragmentPageContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.MediaGalleryContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WikiContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WeblogPostContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.MediaGalleryPostContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WikiPageContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ForumPostContentHandler, CommunityServer.Search" />

    </

     

    task>

    still the job runs :(

    2. I commented the whole config:

     

    <!--

     

     

    <task name="SearchDeleteQueue" type="CommunityServer.Search.Tasks.DeleteQueryRunner, CommunityServer.Search" enabled="false" enableShutDown="true" />

    <task name="SearchIndexJob" type="Telligent.Search.Mapping.ContentHandlerTask, Telligent.Search.Mapping" documentsPerRun="100" enabled="false" enableShutDown="true">

    <handler type="CommunityServer.Search.UserContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.GroupContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ForumContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WeblogContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ContentFragmentPageContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.MediaGalleryContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WikiContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WeblogPostContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.MediaGalleryPostContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WikiPageContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ForumPostContentHandler, CommunityServer.Search" />

    </task>

     

     

    -->

    still the job runs.

    Please help ?

  • First, make sure you are always using overrides and not changing the communityserver.config file directly. (telligent.com/.../using-override-files.aspx).

    Have you verified that you do not have a tasks service running somewhere?   Or multiple web servers that need this change?  Also make sure you recycled your application pool.

All Replies
  • You will need to remove the Search header fragment from your theme, and also disable the search indexing task in communityserver.config.

    At the moment, the only reliance on search is RSS.

  • Perfect, thanks Alex. The search box went long ago in our custom theme, so this is pleasantly easy. I was expecting some pain :)

  • We are experiencing the same issue reported above.  

    Message: There was an error processing search queue message '06674ad6-4b88-4e27-ba59-63234d100c44'.Http error in request/response to http://localhost:8080/solr/update/

    System.Exception: Http error in request/response to http://localhost:8080/solr/update/

    at CommunityServer.Search.Solr.WebRequests.Post(String url, Byte[] bytesToPost, String& statusDescription)

    at CommunityServer.Search.Solr.SolrSearchIndexProvider.RemoveFromIndexByQuery(SearchQuery query)

    at CommunityServer.Search.Tasks.DeleteQueryRunner.Execute()

    We've attempted to disable the searchDeleteQueue and SearchIndexJob in the communityserver.config but it seems to have no affect.  Is there another solution that we should try?

    Thanks for your help in advance.

  • Hi Nick,

    How are you doing this, with an override file or in the CommunityServer.config itself?

    Also are you disabling or removing the task altogether and have you save the web.config once you made the change?

    Thanks

    Adam

  • Hi Alex/Adam,

    I did as mentioned but no success, the job still runs :(

    1. <task name="SearchDeleteQueue" type="CommunityServer.Search.Tasks.DeleteQueryRunner, CommunityServer.Search" enabled="false" enableShutDown="true" />

    <

     

    task name="SearchIndexJob" type="Telligent.Search.Mapping.ContentHandlerTask, Telligent.Search.Mapping" documentsPerRun="100" enabled="false" enableShutDown="true">

    <

     

    handler type="CommunityServer.Search.UserContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.GroupContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ForumContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WeblogContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ContentFragmentPageContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.MediaGalleryContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WikiContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WeblogPostContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.MediaGalleryPostContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.WikiPageContentHandler, CommunityServer.Search" />

    <

     

    handler type="CommunityServer.Search.ForumPostContentHandler, CommunityServer.Search" />

    </

     

    task>

    still the job runs :(

    2. I commented the whole config:

     

    <!--

     

     

    <task name="SearchDeleteQueue" type="CommunityServer.Search.Tasks.DeleteQueryRunner, CommunityServer.Search" enabled="false" enableShutDown="true" />

    <task name="SearchIndexJob" type="Telligent.Search.Mapping.ContentHandlerTask, Telligent.Search.Mapping" documentsPerRun="100" enabled="false" enableShutDown="true">

    <handler type="CommunityServer.Search.UserContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.GroupContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ForumContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WeblogContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ContentFragmentPageContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.MediaGalleryContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WikiContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WeblogPostContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.MediaGalleryPostContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.WikiPageContentHandler, CommunityServer.Search" />

    <handler type="CommunityServer.Search.ForumPostContentHandler, CommunityServer.Search" />

    </task>

     

     

    -->

    still the job runs.

    Please help ?

  • First, make sure you are always using overrides and not changing the communityserver.config file directly. (telligent.com/.../using-override-files.aspx).

    Have you verified that you do not have a tasks service running somewhere?   Or multiple web servers that need this change?  Also make sure you recycled your application pool.